We recently let you know about a PayLink service issue that may have impacted your experience. We wanted to let you know that the issue is resolved. We continual to monitor the fix to validate remediation.
You should no longer experience any issues when using PayLink, but if you do, please reach out to InterPayments Support as soon as possible.
Thank you for your patience and for being an InterPayments customer.
Best regards, The InterPayments Team
Posted Dec 10, 2025 - 01:38 EST
Identified
Hello,
We recently let you know about an InterPayments Portal issue that may have impacted your experience. We wanted to let you know that we’ve identified the root cause of the event and are actively working to resolve it.
We expect the event to be fully resolved shortly. We will send a follow-up notification to let you know when the issue is resolved.
Thank you for being an InterPayments customer.
Best regards, The InterPayments Team
Posted Dec 10, 2025 - 01:32 EST
Investigating
Hello,
We’re currently investigating a service issue that may be impacting your ability to use PayLink. During this event, you may experience 500 errors.
We will keep you up to date with further notifications as we work to resolve this issue. We sincerely apologize for any inconvenience this may cause.