PayLink Legacy Outage

Incident Report for InterPayments Statuspage

Resolved

This issue has been resolved.
Posted Dec 08, 2025 - 12:38 EST

Investigating

We are currently investigating this issue, we will provide more updates as soon as possible.
Posted Dec 08, 2025 - 12:15 EST
This incident affected: Legacy PayLink.